PHP, which is an acronym for PHP: Hypertext Preprocessor, is one of the most commonly used open-source server-side programming languages available out there. Any site or web-based application built using PHP will run on a given server on the condition that a PHP module is enabled, which renders the language really universal and it is not really all that surprising that there are a few million servers that support it and 100s of millions of PHP websites hosted on them. PHP is preferred over HTML because it allows you to build a dynamic website with an abundance of different options. A PHP-based social networking website, for instance, will display unique web content to each user regardless of the fact that the URL will be the same. In contrast, HTML-based websites are static and the page content itself can be updated only manually. Like any other software, PHP has several versions and the version that was used while setting up a certain website must be activated on the web server so that the site can run correctly.

PHP 4 and PHP 5 Support in Cloud Hosting

In case you purchase a cloud hosting package from us, you won’t ever need to ponder whether or not your sites are compatible with the web hosting platform, since several PHP versions are installed on our servers for the sake of your convenience. The Hepsia Control Panel will permit you to choose PHP 5.5, 5.4, 5.3, 5.2 or 4 with just one click and in case you want to change the version, the update will be applied right away. In this way, many years of work on sites created with an older version will not go down the tube. Our hosting platform will even allow you to use a different PHP version for each domain name hosted in your account, which suggests that you can use older and newer scripts simultaneously. Most web hosting companies on the marketplace offer one, sometimes two versions of PHP. In contrast with them, we believe that you should be the one to pick the version that your very own websites will be using.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

Even in case your sites were built with an older version of PHP, you’ll be able to host them in a semi-dedicated server account from us, since we support several versions running simultaneously on our servers and each one of them can be activated for your account with just a click of the mouse from our in-house built Hepsia Control Panel. Apart from the newest PHP 5.5 and PHP 5.4, we also support 5.3, 5.2 and the older PHP 4. The latter has already been abandoned by most hosting suppliers, but we hold that you shouldn’t be forced to modify a website that took several years to create, as older scripting language syntax does not inevitably imply security breaches. Quite the opposite, a rightly maintained site using PHP 4 can be more reliable than a wrongly maintained one using PHP 5. For your convenience, we will also give you the possibility to choose a different version of PHP for each single site within your account.